Back to overview
Resolved

Updates

Jun 10, 2026 at 10:15pm UTC  –  Jun 11, 2026 at 12:15am UTC
Affected services
Palpabl Store Front
Palpabl NMS
Palpabl API Services

Resolved
Jun 11, 2026 at 12:15am UTC

Maintenance ended

Created
Jun 10, 2026 at 10:15pm UTC

Some Palpabl services may become unavailable as we perform updates to our hosting infrastructure.